Wittmann Roboter / Handling

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Hallo ,

      um zur anfangsfrage zurückzukommen weis ich , das man bei der R7 und R8 Steuerung die Geschwindigkeit unter " Setup:Roboter Einstellung " zwischen 1 und 30 % einstellen kann . Das ist dann die Step und Ref Geschwindigkeit .

      Schreibt ihr im ernst nur ins prog x=0 und Y=0 und den rest soll sich der Robi denken ? Wir schreiben richtige Progs mitabfrage ob er im Formbereich und Ablagebereich ist und dann mit Ausschuß ablage ..... und dann fährt er die Achsen zu 0 , aber nicht weil er das will , sondern weil es im Prog so steht .
    • Jo das mit den Vakkum-teil verloren sollte nur ne Spielerei sein damit man sich das Ref. fahren sparen kann :D
      Uziel schreibt ihr alles mit Vabs-Geschindigkeiten? Oder nur die bewegungen im WKZ mit Vabs und auserhalb mit Max % ?
      Meine Ref.Progs sehen meisten wie folgt aus(Auf Demag-Maschinen):


      If Formbereich
      Jmp Form
      Endif

      If Ablagebereich
      Jmp Ablag
      Endif

      Form

      If E (Teilüberwachung Vak01) = Ein
      Jmp Vac_on
      Endif
      Vakuum-01 = Aus
      X: 25 (je nach WKZ)
      Y: 0
      Z: 0
      X: 0
      C: 0
      Band-01: Ein 4.0s
      End

      Ablag
      Vakuum-01 = Aus
      Y: 0
      Z: 0
      X: 0
      C: 0
      Band-01: Ein 4.0s
      End

      Vac_on
      Band-01: Ein 4.0s
      X: 22
      Y: 0
      Z: 1200
      C: 90
      X: 150
      Y: 1300
      Vakuum-01 = Aus
      Time = 0.3
      Jmp Ablag
      End

      Schade, Forum besitzt keine Spoiler Funktion ;(

      Meistens ist noch gerade noch soviel Platz das er mit vorgefahren Auswerfer + Artikel an Hand aus dem WKZ fahren kann. Ist halt von Artikel zu Artikel anders.
      Das mit der Teilüberwachung und den anschließenden auf Band ablegen ist nur bei manchen Artikeln so, meisten klaue ich den Roby den Artikel und fahre dann Ref.

      Edit: sollten wir nicht lieber ein neuen thread aufmachen? Hat ja wirklich nichts mehr mit der anfangsfrage zutun ^^
      Übertriebene Rücksichtnahme ist ebenso schlecht wie mangelnde Aufmerksamkeit!¿
    •      
    • Wieso, der "fährt" doch SO schneller in Ref! Er ist ja schon da... Nene, mach doch was neues auf und gib den Link mit hier rein. Evtl. hat ja doch auf anhieb jemand DEN Trick.

      :)
      ..:: Gruß von Kuka ::..
      ..:: Alle sagten es geht nicht. Dann kam einer, der das nicht wusste, und tat es ::..
    • Also was ich jetzt aufgeführt habe ist auf ner 7ner Serie geschrieben.
      Haben nur ein 6er und da bin ich leider sogut wie nie dranne.
      Übertriebene Rücksichtnahme ist ebenso schlecht wie mangelnde Aufmerksamkeit!¿
    •      
    • Hab mich schon gewundert. Ich meine OK einen 6er kann man auch so schreiben, aber wäre komplizierter bei einfachen pic and place Applikationen.
      ..:: Gruß von Kuka ::..
      ..:: Alle sagten es geht nicht. Dann kam einer, der das nicht wusste, und tat es ::..
    • Habe mal unsere Standartsache geschrieben und die Standart Grunstellung.

      Grunstellung [Grunstellung]
      Ich hoffe das hat geklappt.
      Das mit der VABS habe ich gemacht,da jeder Einrichter den Override anders einstellt. Da konnte ich predigen was ich wollte. Mit VABS steht die Geschwindigkeit fest. Da können die Drücken was sie wollen.
    • Omg Uziel

      Wenn ich mir dein Prog angucke bringst du mich auf (dumme) Ideen.
      Wenn ich die Progs schreiben würde so wie du es machst kapiert keiner mehr bei uns was der Robi macht :D

      Aber ich danke dir für deine Ansicht des Progs! hab schonwieder was dazu gelernt.
      Und ja das mit den Override kenne ich nur zugut! Muss mir jetzt auch mal angewöhnen in allen Progs zumindest die entnahmen mit Vabs zuschreiben.
      Übertriebene Rücksichtnahme ist ebenso schlecht wie mangelnde Aufmerksamkeit!¿
    •      
    • Das ist n 702 bla bla bla. Die anderen sind alle mit %. Da kann man die Bediener nicht Schach matt setzten. Da sind Aufkleber auf denen steht " Override immer 100 %". Seit dem ist es etwas besser geworden. Es dauert halt immer bis die Gewohnheit nachgelassen hat :P
    • Muss mich berichtigen, die 6er Serie hat Vabs, aber wie muss ich die Werte verstehen?
      Leider hatte ich noch keine Zeit mich in eine BA reinzulesen. Die X-Achse hat Werte von 0-2564, Y-Achse 0-3421, Z-Achse 0-2934. Hab es probehalber mal am Anfang des Programm gesetzt, einmal auf alle Achsen auf 200 und einmal auf kurz vor max - da ändert sich aber nichts bei der Geschwindigkeit.
      ..:: Gruß von Kuka ::..
      ..:: Alle sagten es geht nicht. Dann kam einer, der das nicht wusste, und tat es ::..
    •      
    • @Kuka

      Vabs = mm/s
      Versuch das einfach mal:
      vabs: 3000
      Y: 450
      vabs: 200
      Y: 950
      Nur zum Test ob du eine änderung von der Geschwindigkeit sehen kannst.

      @Uziel
      Danke nochmal^^
      Hab den befehl "Jmp Grundstellung bed: Form-offen = Ein" mit eingebaut.
      Funktioniert Super! Hab sogar noch 2 kleine extras mit eingebaut:

      Grundstellung:
      Y: 0
      X: 0 Y: 0 Z: 0
      HG Modus Satzstopp (oder HG Modus Hand aber dann funktioniert Jmp Start ja nicht)
      Jmp Start
      End

      So brauch ich nach einen kurzen Zwischenstopp nur wieder auf Automatik drücken und weiter gehts. Natürlich könnte ich auch einfach Satzstopp drücken aber das macht ja kein Spaß :D
      Das No Vacuum hab ich auch nochmal überarbeitet:

      X: vabs 800
      X: 0
      Vakuum-01 = Ü-Ein alt No_Vac
      Y: vabs 2500
      Y: 0
      Funktion SGM: Auswerfer zurück!
      SGM Start


      No_Vac
      X: Vabs 100
      X: 0 (ging bei den heutigen WKZ)
      Y: Vabs 300
      Vakuum-01 = Ü-Aus
      Vakuum-01 = Aus
      HG Modus Satzstopp
      Funktion SGM: Auswerfer zurück!
      Start SGM
      Wait Form-zu = Ein
      Jmp Start
      End

      So steht der Robi einfach wieder über der Maschine und wartet. Falls er das Teil einfach nur verloren hat und nichts zwischen der Form liegt brauch ich nur wieder auf Automatik drücken und die Maschine läuft weiter.
      (Aber das werde ich vielleicht nochmal überarbeiten ^^ )
      Übertriebene Rücksichtnahme ist ebenso schlecht wie mangelnde Aufmerksamkeit!¿
    • @KUKA
      Die Geschwindigkeiten werden so lange vom Programm benützt bis neue Geschwindigkeiten programmiert werden. Wenn Du mein Programm betrachtest wirst Du feststellen, das am Anfang (Hauptprogramm) Geschwindigkeiten sind. Dann noch mal im Unterprogrammen Entna und ablag. Wenn Du am Anfang Deinens Programmes die Geschwindigkeiten setzt, gelten diese für das gesamte Programm.
      Bei VABS musst Du einfach etwas spielen. Dann findest Du schnell Deine Gewünschte Geschwindigkeit. Alle anderen Geschwindigkeiten müssen natürlich verbannd werden. Du müsstetst aber trotzdem noch mal nachlesen, da die Steuerung auch beschleunigungs werte inne hat. AABS heist das glaube ich. Dadurch wird festgelegt wie schnell die Achse auf Geschwindigkeit kommt. Dann kommt es Dir so vor als würde sie gar nicht schnell fahren. Solltest Du diese programmieren, musst Du nach der Achsbewegung die Beschleunigung wieder auf max setzen, sont behält die Achse die Werte bei (siehe oben)
      @levitate
      sieht ja ganz vielversprechend aus.
      Was passiert wenn die Maschine auf Störung gegangen ist(Zykluszeitüberwachung). Dann muss ich ja Theoretisch die Maschine neu starten. Lässt er dann immer noch zu das der HG nicht in Grundstellung ist?
      Und HG Modus Satzstop kenne ich nicht. Was macht der HG dann genau? Und ist das in der / ner Serie drin??
    • Noch ne Frage:
      Hat von euch schon mal einer das Ablageraster benutzt? Ich habe das schon mal hinbekommen, glaube jedoch das das Zufall war 8| . Wir haben ein Programm aus dem Teile aus einem Ablageraster aufgenommen werden, und in ein Ablageraster abgelegt werden. Da blicke ich aber nicht so richtig durch( hat der Lehrer von Wittmann geschrieben). Und die Infos aus dem Buch kann ich nicht zu 100% umsetzten.
    •      
    • Ja er lässt sich von den Punkt wieder starten ohne das er in Ref. Position ist.
      Er steht ja in Satzstopp.
      Wenn du die Maschine dann wieder startest(Automatik+Start) wartet die Maschine auf die Freigabe von den Robi das sie schließen darf.
      Setze du den Robi dann auf Automatik bekommt die Maschine den Befehl Start SGM(in meinen fall). Dann wartet er kurz bis die Form zu ist und dann jumpt er zurück zu Start.

      HG Modus Satzstopp/Hand findest du unter der Option "More"


      Mein kleines Problem welches ich noch gerne Lösen möchte ist folgendes:
      Wenn die Maschine auf Störrung geht weil der Robi kein Teil hat muss ich die Maschine wohl oder übel auf Hand machen.
      Nur ich hab es jetzt so geschrieben das der Auswerfer vorne stehen bleibt wenn er kein Teil hat. Könnte ja sein das dass Teil ein Auswerfer beschädigen könnte weil es sich irgendwie verkantet hat.
      Fahre ich den Auswerfer jetzt Manuel nach hinten sagt mir die Maschine "keine Freigabe von Robot" also muss ich erst "Betrieb ohne/mit HG" drücken, dann kann ich erst den Auswerfer nach hinten fahren und die Maschine starten.

      Kurz:
      Maschine ist auf Störrung
      Maschine auf Hand
      Robot "Betrieb mit HG" drücken
      Auswerfer zurück
      Maschine starten
      Robot "Betrieb mit HG" drücken
      Robot Automatik

      Das "Robot "Betrieb mit HG" drücken" muss wegfallen. ?(
      Geht ganz einfach wenn ich den Auswerfer in No_Vaccum zurück fahren lasse, möchte ich aber nicht :thumbdown:


      Ps: Sorry schreibe schon wieder zu viel :wacko:
      Übertriebene Rücksichtnahme ist ebenso schlecht wie mangelnde Aufmerksamkeit!¿
    • Also doch mal die BA nehmen... Danke, trotzdem...

      Werden bei euch die Ablageraster nicht mehr mit Makro ausgeführt? Beim 6er sind es ja Makros - Ablageprogramm.
      ..:: Gruß von Kuka ::..
      ..:: Alle sagten es geht nicht. Dann kam einer, der das nicht wusste, und tat es ::..
    • Muss ich heute mal in die Steuerung gucken. Kann ich so aus dem FF auch nicht sagen. Ich glaube aber das das eine harte Nuss ist.
      Vielleicht mit Satzstopp nach Ü alt warten lassen. Wenn der Bediener dann grünes licht gibt, müsste vieleicht mit der Autotaste das Programm weiterfahren. Und dann kann man vieleicht die Auswerferbefehle kommen lassen. Muss ich aber selber erst testen.
      Mal sehen was man mit Satzstop so alles machen kann.
    •      
    • Uziel schrieb:

      Noch ne Frage:
      Hat von euch schon mal einer das Ablageraster benutzt? Ich habe das schon mal hinbekommen, glaube jedoch das das Zufall war 8| . Wir haben ein Programm aus dem Teile aus einem Ablageraster aufgenommen werden, und in ein Ablageraster abgelegt werden. Da blicke ich aber nicht so richtig durch( hat der Lehrer von Wittmann geschrieben). Und die Infos aus dem Buch kann ich nicht zu 100% umsetzten.


      Lehrer? wow
      Ich hatte nie ne Schulung von Wittmann :( alles learning by doing

      Erklär mir das bitte mal genauer. Soll er z.B Teile aus ein Tray nehmen und in ein anderes Tray einlegen?
      Oder meinst du ein Ablegeprogramm?

      Wir haben ein WKZ da muss der Robi Stifte in das WKZ einlegen und sich immer neue holen + das Magazin/Ketten muss er auch weiter fahren lassen.
      Übertriebene Rücksichtnahme ist ebenso schlecht wie mangelnde Aufmerksamkeit!¿
    • Er hat ein Teil aus dem Magazin genommen und in die Form gelegt. Nach dem Spritzvorgang hat er das teil entnommen und in ein Ablageraster gelegt. Den Lehrer hatten wir nur für das eine Programm. Gelernt haben wir auch nichts. Auch alles learning by doing (plug and play).